Author Topic: Pc Engine Duo Repair Log  (Read 164 times)

LostMonkey

  • Newbie
  • *
  • Posts: 4
Pc Engine Duo Repair Log
« on: March 18, 2022, 11:19:45 PM »
I recently picked up a couple of broken Duos to work on in my spare time.

One of them has several missing chips = just leaving it alone for now.

The other is complete, appears to have had chips remove/replaced/reflowed  - not really sure, they just look like they have some extra solder on the legs.

I have gone through and removed any obvious solder bridges on the chips before ever plugging it in.

When it was plugged in, there was no audio/video activity and no response from the CD drive when "Run" was pressed.  It was on for about a minute and I noticed that the left hand (when looking at the front) 7805 was super hot.  Probing around with the multimeter, I found that after that 7805, ground and output (5v) are shorted.

I found a couple of caps that appeared to be shorted, but they were just spots where ground was on one side and 5v on the other - the caps were fine.

I have since removed all of the caps and still have the short. 

Anyone know of any components on the Duo that may be prone to shorting like this?  I am having a hard time finding the culprit.   

The power to the CD side doesn't appear to be shorted.  I do have the other Duo to test continuity etc - so I have been slowly muddling through the two boards looking for oddities, but any advice would be appreciated.

« Last Edit: April 03, 2022, 04:04:26 PM by LostMonkey »

LostMonkey

  • Newbie
  • *
  • Posts: 4
Re: Pc Engine Duo with short to ground
« Reply #1 on: March 19, 2022, 12:11:25 AM »
Ok - well since I removed about 50 caps and it didn't change anything, I decided to go over the legs of all the chips with the braid, flux and iron just in case there was a short there some where.

....and success!  The short is gone. 

Now I get to put those caps back...


LostMonkey

  • Newbie
  • *
  • Posts: 4
Re: Pc Engine Duo with short to ground
« Reply #2 on: March 19, 2022, 05:16:23 PM »
Got the caps back in internal system rom will not boot.

HuCards (select few) will boot, but with completely corrupted graphics.  Sound seems normal.  This might be what the previous owner was trying to fix - hence the two Duos and one with all the chips missing...

I cannot get an Arcade card to boot in it either.

LostMonkey

  • Newbie
  • *
  • Posts: 4
Re: Pc Engine Duo Repair Log
« Reply #3 on: April 03, 2022, 04:09:16 PM »
So at this point, I removed the system rom chip and discovered that 6 of the pads had been lifted or were missing altogether.  I am currently in the process of rerouting those pins...

In the meantime, I have a video of the output. I am not sure if this is bad ram, bad Hu6270 or possibly more bad soldering on the chips that were removed and replaced by the previous owner.  I did remove and resolder one of the ram chips and did get a noticeable improvement (the video below is the improved version).

Note that some text is legible, but most sprites are scrambled.

https://youtu.be/fzscpBceC8c